DNS Outage
Incident Report for Python Infrastructure
Postmortem

The largest change to come out of this incident is that we will be moving the status page for the Python Infrastructure to https://pythonstatus.com in the coming days.

Due to the nature of the incident, https://status.python.org is resolved from the same DNS provider as the remainder of python.org. We have registered the new domain, and will run its DNS from a different provider for incidents like this in the future.

Posted Oct 21, 2016 - 14:05 UTC

Resolved
Upstream provider has closed the incident, we have verified that resolution for python.org domains is restored.
Posted Oct 21, 2016 - 14:01 UTC
Monitoring
We are continuing to monitor the situation with our DNS provider. Traffic patterns are indicating that DNS is resolving for most users.
Posted Oct 21, 2016 - 13:17 UTC
Investigating
DNS infrastructure for python.org is currently unavailable. Records for all subdomains are currently not resolving.
Posted Oct 21, 2016 - 12:35 UTC
This incident affected: python.org (python.org - CDN), mail.python.org (Message Handling Services, Mailing Lists and Archives - Mailman), docs.python.org (docs.python.org - Backends), and wiki.python.org.