Site wide issue in PSF Infrastructure
Incident Report for Python Infrastructure
Resolved
This incident has been resolved.
Posted Feb 12, 2024 - 21:06 UTC
Monitoring
Our new internal CA has been rolled out across the infrastructure and we are monitoring for remaining service impact.
Posted Feb 12, 2024 - 18:07 UTC
Identified
Our internal Certificate Authority certificate has expired causing cascading outages across multiple services. An updated CA has been created and we are working to roll it out to restore service.
Posted Feb 12, 2024 - 18:00 UTC
Investigating
A site wide issue is impacting many services hosted in the PSF infrastructure.
Posted Feb 12, 2024 - 17:50 UTC