Object storage provider outage
Incident Report for Python Infrastructure
Resolved
This incident has been resolved.
Posted Jun 22, 2023 - 01:59 UTC
Monitoring
Our mitigation has decreased overall latencies, but they remain elevated over normal operation. As our provider's service recovers we expect to see a return to baseline.
Posted Jun 21, 2023 - 23:45 UTC
Update
We are also implementing our own change to guard against excessive latencies from the provider.
Posted Jun 21, 2023 - 22:57 UTC
Update
We're in communication with the object storage provider and are waiting for them to rollout a fix.
Posted Jun 21, 2023 - 22:52 UTC
Identified
We have identified an issue that is impacting latencies for files.pythonhosted.org, resulting in timeouts for a portion of requests.
Posted Jun 21, 2023 - 22:46 UTC
Investigating
We are currently investigating an issue with our object storage provider.
Posted Jun 21, 2023 - 21:38 UTC
This incident affected: PyPI (files.pythonhosted.org - Files).